Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Rumble_T

Members
  • Content count

    197
  • Joined

  • Last visited

3 Followers

About Rumble_T

  • Rank
    Senior Jack Wagon

Recent Profile Visitors

2,326 profile views
  1. Looking to buy a Jeep SRT preferably white exterior, black interior with some upgrades 2014-2015 w/ less than 60k miles. Please let me know if you are interested in selling.
  2. Please text or call for additional questions. http://atlanta.craigslist.org/nat/cto/5436110297.html
  3. FYI guys, I installed the Paramount TCM and no limp mode issues now. I don't know why it works, just know that it does work for me. The issue I'm having now is in just plain automatic mode the car acts like a pig but if I use the autostick, I am going all the way to redline and car is shifting on its own without going in limp mode. I'm sure there are cars out there that had the same issue and it was something mechanically wrong but in my case, everything was brand new. I have a couple of friends that had the same issue and told me the TCM would fix it as well. Hope that if anyone having similar issues like me is reading this, getting a new tcm may work for you.
  4. Why is that? Had to pay for it..
  5. The transmission is 2 months old and this has been my 3rd time driving it. I don't think it's the transmission. Same per above, transmission is brand new..I called Bill and he advised to get the Paramount TCM...going to install that tomorrow and see if it fixes it.
  6. So looks like its not shifting fast enough therefore I'm hitting the rev limiter and going into limp mode. Why does it lag so much to shift? How do I fix it?
  7. Has happened on down shift yes.. I can get the 5.7 above 6200rpms..I've done it before the build..have gotten it up to 6400rpms before problem FREE. I HAVE a built trans.....STAGE 3 Paramount Transmission. I am running a BUILT transmission too (Stage 3 Paramount Transmission) and am running stock TCM and Diff. I don't have any tune that the limp mode was good. Mike sent me the car back and I've been having limp mode issue ever since, he had the issue a few times too with the same code saying incorrect gear ratio. I will try going to stock and then reloading the tune to see if that fixes any glitches that could've happened...
  8. P0730 is the code. I changed my shift points to stock but still no luck :/ The tire diameter is 275/40/20 in the rear.
  9. I have a 5.7 TCM however I've shifted at 6400rpm before my build. Now that my build is done, I'm getting issues with limp mode. My build consists of 393 stroked 5.7, Paramount Stage 3 Transmission, Vortech V3 10-12psi. Mike at OST is the one who built my car and he's working on the tune...He mentioned that he doesnt know anyone with the stock tcm above 600rwhp. Any suggestions on what to do? Do I need a new TCM or is it all in the tune? Also, when I do go in limp mode, the check engine light comes on and the code is incorrect gear ratio. I never changed my gear ratio, it's 3.06 and when I look at the tune, 3.06 is selected....
  10. Let me be more specific, sorry about that.... Stage 3 Paramount Transmission...shifting at 6400rpm or less but still hitting limp mode. Getting limp mode when WOT from 0 and sometimes on downshifts.
  11. Car keeps hitting limp mode..is it because of a stock TCM? I have a Stage 3 Paramount Transmission, Stroked 5.7 to a 393, Vortech V3 pushing 10-12psi.
  12. Price reduced to $600.
  13. My car has slow crank start a lot, especially when hot. Have to do what chukarboy said with pushing gas pedal down...
  14. Yes, stock manifold. I still have the stock manifold on mine..I bought this one to get ported so I can replace the one I have now but not enough funds so decided to sell. By the way, dyno'd 653rwhp and 692rwtq with stock pulley on V3 10-12psi
  15. Price reduced to $675.