Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Search the Community: Showing results for tags 'ram valve spring'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Up Top News & Notes
    • News & Announcements
    • Newbie Check-In
    • Events, Shows, Meet & Greets
  • General Info, Mods, Kills, & Track Chat
    • Knowledge Base
    • Garage & Tool area
    • General Discussion
    • Kills & Track Chat
    • Performance
    • Exterior
    • Interior
    • Wheels, Tires, Brakes, Suspension
  • Vehicles
    • Cars
    • SUVs
    • Trucks
    • Old Mopar Muscle
  • Nothing but Motors
    • V8
    • V6
    • I4
  • Classifieds
    • Cars for sale/WTB
    • Parts for sale/WTB
    • Anything for sale
  • The Private Parts
    • "Other car talk"
    • Anything goes.
  • Vendors
    • A2Speed
    • BFNY Performance
    • Billet Technology
    • Demon Performance
    • Driveshaft Shop
    • eastcoastmoparts.com
    • Hemituner Performance
    • HHP - High Horse Performance
    • Inertia Motorsports
    • LMI Intakes
    • Laukemper Chryser-Dodge-Jeep-Ram-Chevrolet

Calendars

  • Modern Mopar Forum Community Calendar

Categories

  • Service Manual
  • Parts Catalog
  • Owners Manual
  • Installation Manuals
  • Sales Materials
  • Misc.

Categories

  • Vehicles

Categories

  • Groups

Found 1 result

  1. So a bud of mine that has a '04 Ram was telling me that there seems to be an issue with "many" 03-04 RAMs having weak valve springs which break and then drop the valve in the cylinder, basically grenading the engine. I had never heard this and sure enough after checking out some threads on dodgeforums, it seems to have some merit. Some have got lucky and it didn't drop the valve but others was total loss. The failure seems random regarding mileage. I am at 116k on my 03 so this kind of worried me. The fix seems to be to replace the springs with 6.1 valve springs. Anyone else hear of this issue?