Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Search the Community: Showing results for tags 'trinity'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Up Top News & Notes
    • News & Announcements
    • Newbie Check-In
    • Events, Shows, Meet & Greets
  • General Info, Mods, Kills, & Track Chat
    • Knowledge Base
    • Garage & Tool area
    • General Discussion
    • Kills & Track Chat
    • Performance
    • Exterior
    • Interior
    • Wheels, Tires, Brakes, Suspension
  • Vehicles
    • Cars
    • SUVs
    • Trucks
    • Old Mopar Muscle
  • Nothing but Motors
    • V8
    • V6
    • I4
  • Classifieds
    • Cars for sale/WTB
    • Parts for sale/WTB
    • Anything for sale
  • The Private Parts
    • "Other car talk"
    • Anything goes.
  • Vendors
    • A2Speed
    • BFNY Performance
    • Billet Technology
    • Demon Performance
    • Driveshaft Shop
    • eastcoastmoparts.com
    • Hemituner Performance
    • HHP - High Horse Performance
    • Inertia Motorsports
    • LMI Intakes
    • Laukemper Chryser-Dodge-Jeep-Ram-Chevrolet

Calendars

  • Modern Mopar Forum Community Calendar

Categories

  • Service Manual
  • Parts Catalog
  • Owners Manual
  • Installation Manuals
  • Sales Materials
  • Misc.

Categories

  • Vehicles

Categories

  • Groups

Found 2 results

  1. I had to retire the LC-1 due to a melt down during the dyne sessions at AJ's. Nobody knows how it happened but it went south. So I decided to go with the AEM after reading many great reviews of it here. Now I'm stuck and need some help. I can't seem to get a good reading to the Trinity when I feed the analog line to it. I'm not sure if the gauge needs to be configured in some way, or if i'm just retarded when I input the values for the PID but the readings are all over the place. The installed gauge is reading right. Diablosport's website was a dead end and the instructions from AEM leave much to be desired. Any help will be appreciated. Thanks, Matt
  2. After racing and datalogging this weekend I go to download my datalogs and get this message... An internal update has been installed that requires a reboot. Please unplug your Trinity briefly to cycle the power(1) I have plugged it into my laptop, my desktop and the car several times with at least 5 minute in between each time. The last time I unplugged it I left it unplugged to 2 days, due to work, and plugged it in today and still get this message. Anyone know whats up???? I need those datalogs