Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

pmaillet23

Emissions Inspection Failure

61 posts in this topic

Ok so I go to the dealership, failed inspection twice for Oxygen Sensor and Catalyst Monitor. I have a 2014 RT with the Magnuson Supercharger from Arrington.  I call Arrington and ask if its the tune causing the O2 failure when doing the Emissions test and if there is anything they can do to pass the inspection, they tell me no, 2011 and up have not came out with a EO for the maggies.  So tell me, I know there are plenty of 2011 and up running maggies that need Emission testing, any issues with this or what can be done to pass an inspection?

Share this post


Link to post
Share on other sites

O2's turned off?

 

Cels?

 

Stevo

 

Exactly the problem I had on my 2010, rear 02's turned off and failed inspection. Had the tune tweaked and passed with flying colors.

 

As mentioned headers & cats will have a lot to do with it also. I don't think you will ever get long tube headers to pass in Texas.

Share this post


Link to post
Share on other sites

The rear O2's are turned off. Are you using the Trinity or Arringtons bullshit black box?

Call API back and get them to write you a tune with them turned on this has nothng to do with EO, howeer if they want to play tht bullsht game they may want to look at what happend to Edge by the EPA.. After you upload the new tune drive the car for 30-45 minutes so they get to the ready state and you'll pass emissions.

If API won't do it tell them to suck a dick and get a hold of Mike @ OST or AJ, athough if you're on the black box you may need to buy a Trinty.

Share this post


Link to post
Share on other sites

Ok so I go to the dealership, failed inspection twice for Oxygen Sensor and Catalyst Monitor. I have a 2014 RT with the Magnuson Supercharger from Arrington.  I call Arrington and ask if its the tune causing the O2 failure when doing the Emissions test and if there is anything they can do to pass the inspection, they tell me no, 2011 and up have not came out with a EO for the maggies.  So tell me, I know there are plenty of 2011 and up running maggies that need Emission testing, any issues with this or what can be done to pass an inspection?

If your not using an Arrington "black box" shoot me a copy of your tune. If it's not locked I'll fix it and email it back to you - no charge

Share this post


Link to post
Share on other sites

Yes they could fix it if they wanted to...good old API.

 

stock manifolds..stock mids...no reason it shouldn't pass.

 

Your rear O2 sensors are turned off.  Get that fixed and it'll pass.

Got to say guys your WAY off on this one and I don't even have a dog in the fight. The o2's are on boys Now what???

AJ

Share this post


Link to post
Share on other sites

Rear O2s failing for not ready....every time I've seen that they're either off or haven't gone through the ready set cycle. If there's something else I'd be interested to learn what it is.

Share this post


Link to post
Share on other sites

Rear O2s failing for not ready....every time I've seen that they're either off or haven't gone through the ready set cycle. If there's something else I'd be interested to learn what it is.

 

Fail and NOT READY are two very different scenarios. In order to fail it has to run the test, not pass, then rerun the test intrusively, not pass again then illuminate the MIL. If its not running the test or is being driven outside the criteria to run the test you have to look and find out WHY. Could be one of 50 global disables, like Fuel level, Ambient temp, outside of rpm, outside of speed, ect. Before everyone rushes to judgement there are some serious questions that need to be asked, There is a saying that you find out who your friends are when you have NOTHING, Its so true. And your only as good as your last mistake in the court of public opinion ;) Like I said I do NOT have a dog in this fight any longer but I DO have the courage of my own convictions. Don't always assume that someone is getting screwed. Does anyone look at the glass half full anymore?

AJ

Share this post


Link to post
Share on other sites

Mines was NOT READY and it happened to be that the rear o2 were off. If he is failing then that is a different problem. Like AJ said not PASSING and NOT READY are two different things. IF the OP can give more details it would help solve his problem.

Share this post


Link to post
Share on other sites

Got to say guys your WAY off on this one and I don't even have a dog in the fight. The o2's are on boys Now what???

AJ

Here's my question to you AJ, how could you be so sure they are not turned off? Im not trying to pick a bone here, there could be multiple things here causing it. And it doesn't help me the Mech was like well i don't know what it is, they guy didn't know apple butter from baby shit. You may be right, they way i drive isn't exactly normal nor by law which could cause the o2 to not pass twice. The guy couldn't go into details, they just had me drive it until tank was between 1/2 and 3/4 full and came back to re test.

Share this post


Link to post
Share on other sites

Here's my question to you AJ, how could you be so sure they are not turned off? Im not trying to pick a bone here, there could be multiple things here causing it. And it doesn't help me the Mech was like well i don't know what it is, they guy didn't know apple butter from baby shit. You may be right, they way i drive isn't exactly normal nor by law which could cause the o2 to not pass twice. The guy couldn't go into details, they just had me drive it until tank was between 1/2 and 3/4 full and came back to re test.

I sent you a pm last night. It stated that if the last tune written was API sc r3 then they were on. I know because I looked at it before I sent you the pm.

Thanks

AJ

Share this post


Link to post
Share on other sites

Ok my thing was more along the lines that they dismissed him right away basically telling him it was an a 2011+ and it was just how it is..

 

Im no tuner and never will be but I have seen something like this before and a new tune fixed it but maybe its a completely different scenario. ..just didnt sound like it talking to him.

 

Paul I hope you get it squared away.

Share this post


Link to post
Share on other sites

 I call Arrington and ask if its the tune causing the O2 failure when doing the Emissions test and if there is anything they can do to pass the inspection, they tell me no...

 

Was this before or after AJ left?  lol

 

On another note, my cup of coffee is 1/4 full right now.  I'm going to go get a warm up. :)

 

Hope you get it figured out. This kind of stuff scares me if I ever move out of Indiana with long tubes, no cats, and a Procharger.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now