Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
05hemiram

Timing Chain

Hello all.

 

Hoping to get some feedback.

I have an 05 Hemi Ram Sport, fab truck, love it.

 

Though my question is, upon start up, and only when cold, I get about .5 seconds of what sounds like lifter noise, goes away right away, then a noise I can't even describe. Yet goes away when warm, and runs as smooth as silk.

 

Even when cold, it still idles great, just makes this sound. Oil pressure is fine, idle is great. Completely smooth.

 

Had a mechanic check it out, stethoscope test, even compression test, no problems.

 

Chrysler told me it's timing chain rattle, a lot of 5.7 Hemi Rams do this. No worries, just leave it.

 

Anyone else experience this??

 

Thanx much,

 

Daryl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0