Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Drp6982

My Bes Update

59 posts in this topic

Finally got my Charger buttoned up for the most part in regards to getting her tuned, dyno'd, and 1st track outing. 

 

Found a Mustang dyno in West Palm and had Brian from Diablo there to tune it for NA and Spray.

 

To say this dyno was stingy is a complete understatement and you will see why. 

 

When we started we were really looking to get a base tune for motor and spray to give us a good place to start, Brian said he would really like to go to the track with me to log it and really dial in a more aggressive tune. Got the motor to the point she is running 24 degrees of timing and a somewhat conservative AF (12.1-12.2 with 11.7-11.9 up top)

 

 

 

 

Car made a whopping 515RWHP/565Lbs of TQ..... needless to say I was very disappointed with the numbers, but the power curves from the dyno seemed very promising and climbed all the way up to 7000 RPMS...

 

Regardless of how stingy we all say are dyno's are, I was really surprised it was this low on a 440. After all my older PWR 426 put down 541WHP on AMP's mustang dyno....

 

 

Well, I was supposed to hit the track on Wed of next week with Brian but I got antsy and decided I would head out tonight just to do a few motor passes.... I really wanted to know if this motor was slower then the previous....

 

 

I took her out without adjusting a thing and made my first hit with the new motor

 

 

PBIR%205.8%201st%20time%20out_zpsxghow8e

 

 

 

Was pleasantly surprised to see a solid 4mph pick up over my previous motor in similar DA....  Unfortunately I am currently having problems with my starter motor when it comes to heat and compression of this motor. I could not get her to comfortably turn over so I had to pack it up for the night. (I was having this issue toward the end of days on the last motor but we thought at the time it was a battery issue)

 

 

Long story short I think this motor has a ton of promise.... I think with some more timing and raising the RPM on the two step (Set at 2200 this run) she should run some 10.4-10.5s and better once I get a chance to run in good air like ATCO....

 

 

Real curious to see what the nitrous will do to her. 

 

 

But first things first, I have to get to the bottle of my starting issue and then get some more seat time and quick. I do want to go to VMP but wont if Im too far off from finishing up.....  crossing my fingers

 

 

Share this post


Link to post
Share on other sites

Outstanding pickup! 4mph is a nice gain :)......she is going to be a absolute terror on the bottle!

 

That's a intresting issue with the starter....that much compression is going to be tough on it.

Share this post


Link to post
Share on other sites

Outstanding pickup! 4mph is a nice gain :)......she is going to be a absolute terror on the bottle!

 

That's a intresting issue with the starter....that much compression is going to be tough on it.

 

 

yeah, Im hoping to get her closer to the 130 mark in my air down here.... think its doable since she could use a bit more timing and launch can be improved.....   

 

yeah curious about how the spray will do to....

 

 

I am using a mini starter. When I did my TH400 it was one of the first few peeps and the bellhousing ATI uses relocates the starter to the other side of the motor. We had to use a mini starter which I believe is whats used on some of the Drag Pak cars.... she has been working fine for 2 years on my 13.6:1 PWR motors but toward the end it was harder and harder to start. Problem is the starter is practically right on the header since the Kooks were designed with the starter on the other side. I have a replacement solenoid on order and I hope that does the trick... at least for a year or two... if not I might have to look into a Reid housing which would allow me to go back to the other side and get a bigger starter

Share this post


Link to post
Share on other sites

I think your right, 130 seems very feasible. Wow, I didn't realize your lAst motor had that much compression. I'm surprised the mini starter lasted as long as it has given its environmental challenges!

Share this post


Link to post
Share on other sites

Nice first hit !

 

Reid bellhousing FTW - no problems spinning ny 14.5:1 engine with the stock Chrysler starter.

Holy crap....you running alcohol in that thing?? lol

Share this post


Link to post
Share on other sites

I really dont know Dan, still pretty early on what this motor will and can do. I know BES said dont go over a 350 shot and to be honest, Im not looking for more then that. Seems like thats a reisky threshold to cross and get right

 

I think the goal for me is to try and hit an 8.99 on a 300 shot.....  not sure if its possible but thats what I have in mind..... might have to knock it up to a 350 shot

 

What was your best ? 8.92 ? 

Share this post


Link to post
Share on other sites

Wait... You knew about this limitation? Knowing you, this seems all wrong. Yes, 301+ has been a tough road so far buuuuut......

 

 

yeah, I knew it would not be a 500 shot motor. Grant it I was surprised that I had to send the heads out for quenching to run a 300 & 350 shot when I was told it would be fine as is but dont plan on going over.

 

To be honest, there is something to be said for just the NA guys, alot less shit to deal with

Share this post


Link to post
Share on other sites

NA ftw! (broken record, I know).

 

If it's not huge already, make sure your positive cable to the starter is a bit on the large side. Helps with the slow cranking.

 

 

yeah, all cables have been upgraded....   

 

I went ahead and ordered a whole new starter, identical to what I have. I checked into the Reid housing and couldn't get it in time for VMP. Im just hoping I can get the starter in time to get back to the track and finish tuning

Share this post


Link to post
Share on other sites

I ran a slew of 9.0's on the 300 shot. You should be able to tap 8's with that or a 350.

 

 

Oh, I was not aware of that. I thought you were really close on the 400 shot and broke it on 600....

 

what kind of mph were you seeing specifically on the 300 shot ? 

Share this post


Link to post
Share on other sites

I don't remember, I'll try to find it. I could be wrong and it was the 400 shot I was running the 9.0's on but I think I nailed the 300 shot the same day I went for the 600 shot.

 

Keep in mind the 600 shot was no where close to being dialed in and I ran 8.92 and the motor had let go at around 1000 feet the one and only attempt that day.

 

My previous track day trying the 600 shot we were fighting spark issues.

Share this post


Link to post
Share on other sites

Oh ok... I thought the 300 shot you did was around 9.4x and the 400 was in the 9 second flat range....

 

 

Curious to see how low of a mph is really needed to run the #

 

 

Seems like for those who have run 9.5s I am trapping the lowest mph

Share this post


Link to post
Share on other sites

You are right, 9.4 @ 147 mph on the 300 shot and 9.0 @ 150 mph on the 400 shot and 8.91 at 152 mph on the 600 shot.  Mph and ET are kinda off on the 600 shot as it wasnt pulling so well the last little bit ;)

 

First8_zps7d73fd2b.jpg

 

96a649e3-3bac-4281-8920-a903152da4c1_zps

 

This is probably my best on the 300 shot

 

20130504_183310_zps158eba06.jpg

 

 

918_zpsd4b9c393.jpg

Share this post


Link to post
Share on other sites

Thanks for posting the slips Dan, thats some awesome MPH on the 300 shot.

 

Im not sure what Im going to do at VMP. Im waiting for my starter to come in which means I only have one more T&T night local to dial the car in which wont be enough. I will probably have to come to VMP for Bill's private rental and try to do all the tuning myself which is not ideal but I guess I gotta do what I gotta do

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now