Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

RTWildChild

Rpm Transmission Install

162 posts in this topic

What was the lead time to get one? The mile is coming up and I'm determined not to make any changes beforehand, but the transmission is in pretty bad shape. It's getting hard to get it into any gear. Might be an issue after replacing the clutch, but everything feel s nice on the clutch, just have to really fight it into gear.

Share this post


Link to post
Share on other sites

What was the lead time to get one? The mile is coming up and I'm determined not to make any changes beforehand, but the transmission is in pretty bad shape. It's getting hard to get it into any gear. Might be an issue after replacing the clutch, but everything feel s nice on the clutch, just have to really fight it into gear.

I had the same issue, super hard to engage 2nd and mainly 3rd; once I put the RXT clutch, 3rd went completely out within a month; but that was w me again having to force it into gear and gettin on it about 70-80% of the time. It's to hard not too lol.

 

I Purchased the transmission on June 30th, had it delivered and on the back of my truck by August 7th.

 

P.s. Good luck in the mile

Share this post


Link to post
Share on other sites

I'm trying to determine if it's an alignment/ shim issue. I'm thinking I will put it on stands and see if I get any wheelspin with the clutch engaged before ordering.

Share this post


Link to post
Share on other sites

^^ That's why I mentioned that earlier.  My original RXT clutch was about 1/2? too short and it fubared my RPM Trans AND TOB.  Gave me lots of fits at the track as is WOULD NOT shift in to 4th at WOT, but shifted fine on the street.  When we pulled the trans the TOB exploded and came apart.  Trans was fried and RPM rebuilt it.  New RXT clutch went in and it's been great, but what a PITA.

Share this post


Link to post
Share on other sites

Won first place in the Mopar Battle Royale at San Antonio Raceway. Transmission is holding up great and shifting with ease while going down the track.

 

Thought I would share with yall this video. I can just play the last few seconds of this race over and over just to listen to the crowd at the end. It was the "dessert" that followed a nice dinner.

 

 

Was a bit rusty from not being at the track for it being closed but time to work on gettin my 60ft back down but definitely no need for a school to teach me on staying consistent with MY CAR, just time and practice.

Share this post


Link to post
Share on other sites

Good deal Steven. I gotta get back to the track.

Josh@HHP did some good adjustments for last night & Hell yeah, let me know when you go. I'll meet ya. This weekend is the Tim Duncan arm drop race but don't think I'll go cause it's gonna be shit packed. Friday nights are good though to get in a good amount of runs.

Share this post


Link to post
Share on other sites

Yea, the Tim Duncan thing will be packed but its a 5k payout. I am thinking on it this week. $100 buy in but shit, I am a gambler. You and I both have trophies from S.A. 

Share this post


Link to post
Share on other sites

Yea, the Tim Duncan thing will be packed but its a 5k payout. I am thinking on it this week. $100 buy in but shit, I am a gambler. You and I both have trophies from S.A.

Oh sh*t!!! I didn't know about the payout... Hmm very tempting.

 

Oh yeah, that's right! I forgot you took one home as well before the track closed. Time to put a second one on the board for you as well. ;)

Share this post


Link to post
Share on other sites

Oh sh*t!!! I didn't know about the payout... Hmm very tempting.

 

Oh yeah, that's right! I forgot you took one home as well before the track closed. Time to put a second one on the board for you as well. ;)

 

I was just reading that there is some closest time match up caveat and heads up after they match up the closest times. I don't know how that means anything other than the fastest car wins and leaves us middle of the road guys donating to the prize money.

Share this post


Link to post
Share on other sites

@JDW - wow....yeah I saw the postings on the SAR raceway FB page. ONLY 16 spots out of 100 handed out for $5k after you pay $100....No thanks, not anywhere close or confident with not knowing how many will be running 8, 9, 10, 11, 12, & 13 seconds. Looked at the registration form still 89 spots to be filled...lol

 

@Toofart & Speedy - Thanks fellas, much appreciated.

Share this post


Link to post
Share on other sites

What was the lead time to get one? The mile is coming up and I'm determined not to make any changes beforehand, but the transmission is in pretty bad shape. It's getting hard to get it into any gear. Might be an issue after replacing the clutch, but everything feel s nice on the clutch, just have to really fight it into gear.

Did you lube the spline shaft during the clutch install? There is a star # out its like a TSB. Basically it talks about hard shifting blaming the discs binding against each other on the input shaft. So as youmay have the clutch disengaged the trans is still spinning. Just a thought..70..

Share this post


Link to post
Share on other sites

I would honestly hate to think I busted this damn transmission with it being a Level VII but seems like I'm having a hard time engaging 3rd again (definitely not as bad as before, because it does engage and doesn't need a lot of attempts to engage) but seems like I'm missing 3rd a lot when I'm going through the gears during racing OR doesn't fully engage 3rd. Doesn't feel like a good throw or complete clicking/engagement. Not having to apply much force whenever I am shifting into 3rd during normal daily driving, but shifts also don't feel consistent with the engagement. Feels like it engages half way n grabs or something. *sorry if not to good of description*

 

Would not have replacing the throw out bearing cause this? RXT clutch going bad? Any suggestions or recommendations on what to look at?

Share this post


Link to post
Share on other sites

My stock clutch would behave like that after a few passes. I think it was the fluid getting hot. I believe Speedy found a different fluid that worked better before he switched out his clutch, you may want to ask him. I'm in the process of swapping clutches myself, so I never played around with switching fluids... yet.

Share this post


Link to post
Share on other sites

I'm thinking the clutch as well. Gonna bleed it and check the shifter before I jump to conclusions.

 

Did you check the air gap on the throw out bearing when you installed the new clutch ? I know of several people that have had these same symptoms and ended up having to shim the throw out bearing. It seems like the throw out bearing isn't traveling enough to disengage the clutch under high rpm loads.

Share this post


Link to post
Share on other sites

Did you check the air gap on the throw out bearing when you installed the new clutch ? I know of several people that have had these same symptoms and ended up having to shim the throw out bearing. It seems like the throw out bearing isn't traveling enough to disengage the clutch under high rpm loads.

No sir, haven't done that. I will definitely check on that as well. I think I'm gonna be calling it quits for now on the racing until I can put it back on the lift and see what can be going on. Probably do all that when I put on the one piece driveshaft. Snapped a stud on one of the wheel hubs as well recently so looks like I have a couple agenda items.

 

#LoveThisShit

Share this post


Link to post
Share on other sites

Well did some minor fluid stuff n no go, same symptoms.

 

Didn't have these symptoms when I first installed the RPM transmission awhile back.

 

Car goes through gears/shifts fine when it's off/parked. During normal driving gears feel rough/notchy at times when shifting or won't fully engage but still grab.

 

When I am racing and above a higher RPM to speed shift, I'll miss third most of the time like it's not engaging properly or opening up to engage properly similar to like a delay, just started happening recently.

 

If I were to be racing and go to the higher RPM I have to pretty much granny shift to get it into 3rd.

 

Any thoughts? Maybe master cylinder or slave cylinder?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now