Welcome to Modern Mopar Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

RTWildChild

Rpm Transmission Install

162 posts in this topic

Curious what the broken parts look like.

Honestly, I didn't know what the hell I was looking at, but it had nicks in grooves/teeth and real rough surfaces. Could see how disruption would be caused but damn surprised so little of nicks/worn surfaces would cause issues but then again it explains missed shifts at times or during WOT shifts. I'll post a pic later when I get home.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Hopefully you can get it together and enjoy it.

No doubt I can get it together, just finding the time to fix and start enjoying it is the problem. Shooting for this Saturday. If not, I'll need to wait till I get back from a work/business trip (Dec. 2).

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Funny how fast you can pull the trans and reinstall after you've done it a few times.

Absolutely, I don't mind the knowledge but damn wish I could've learned another way than through this scenario.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Been super busy with work after I got back from Vegas, and just waiting to find some time to put it back together. Then do some logging for AJ.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
any updates wildchild?

 

 

No lol Recently had a little girl after I got back and much time have been going to work and baby.

 

It's just outside sitting up on jacks with a brand new transmission, wheels, and drag springs sitting outside of it

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I did however attempt it one time, and the transmission wasn't slipping all the way through the clutch to where the bell housing wouldn't end up flush with the motor

 

I'm thinking it's because of all the months I had it sitting outside; exposed to weather and such. Took off the clutch & realigned; and now back to the transmission sitting there to be put on.

 

 

Sent from my iPhone using Tapatalk

 

Share this post


Link to post
Share on other sites
On ‎7‎/‎24‎/‎2017 at 1:25 AM, R/TWildChild said:

 

No emoji26.pnglol Recently had a little girl after I got back and much time have been going to work and baby.

 

It's just outside sitting up on jacks with a brand new transmission, wheels, and drag springs sitting outside of it

 

 

Sent from my iPhone using Tapatalk

Well, CONGRATS on the baby girl!!.

Share this post


Link to post
Share on other sites
Well, CONGRATS on the baby girl!!.


Thanks brotha. If I had money to spare, I'm sure it would already be done and rolling. Just gotta let time do its thing I suppose


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now